Discussion:
Error 1693
(too old to reply)
Tomukas
2006-07-31 07:14:01 UTC
Permalink
Trying to install one program (TecDoc), Windows installer returns an error
message - Error 1693 - Invalid command line argument. Consult the Windows
Installer SDK for detailed command line help.

Didn't find anything helpfull in net. System - Windows XP Home Edition SP2.

Installs fine on any another computer.
Rob Hamflett
2006-07-31 07:50:13 UTC
Permalink
Is thjis of any help?

http://www.pcreview.co.uk/forums/thread-1544290.php

Rob
Post by Tomukas
Trying to install one program (TecDoc), Windows installer returns an error
message - Error 1693 - Invalid command line argument. Consult the Windows
Installer SDK for detailed command line help.
Didn't find anything helpfull in net. System - Windows XP Home Edition SP2.
Installs fine on any another computer.
Dennis Bareis
2006-07-31 07:53:47 UTC
Permalink
Hi,
Post by Tomukas
Trying to install one program (TecDoc), Windows installer returns an error
message - Error 1693 - Invalid command line argument. Consult the Windows
Installer SDK for detailed command line help.
Didn't find anything helpfull in net. System - Windows XP Home Edition SP2.
Installs fine on any another computer.
As far as I can see 1693 is undocumented and Windows Installer seems to display a
syntax dialog even if silent (Bug #1) and then returns a return code of 0 (bug #2)...


A verbose log should tell you more:

http://users.cyberone.com.au/dbareis/makemsi/msiexec_exe_verbose_logging.htm
http://users.cyberone.com.au/dbareis/makemsi/windows_installer_logging_policies.htm

Bye,
Dennis
Dennis Bareis [MVP] (***@KillSpam.gmail.com)
http://users.cyberone.com.au/dbareis/index.htm
Freeware Windows Installer creation tool (+ "ORCA automation"):
http://users.cyberone.com.au/dbareis/makemsi.htm
Tomukas
2006-07-31 11:49:02 UTC
Permalink
I can't vreate a verbose mode using command line (getting error -
"Asplication only can be installed running setup.exe file), and about
registry - I've added these keys be4, bt I can't find log file in
Windows-.temp folder...
Dennis Bareis
2006-08-01 09:53:28 UTC
Permalink
Post by Tomukas
I can't vreate a verbose mode using command line (getting error -
"Asplication only can be installed running setup.exe file), and about
registry - I've added these keys be4, bt I can't find log file in
Windows-.temp folder...
Did you look in YOUR temp directory, if you can't find them try:

dir c:\MSI*.log /s

Bye,
Dennis
Dennis Bareis [MVP] (***@KillSpam.gmail.com)
http://users.cyberone.com.au/dbareis/index.htm
Freeware Windows Installer creation tool (+ "ORCA automation"):
http://users.cyberone.com.au/dbareis/makemsi.htm

Continue reading on narkive:
Loading...